PHP-Nuke ‘sid’参数SQL注入漏洞

漏洞起因
SQL注入错误
危险等级

影响系统
PHP-Nuke 8.2

不受影响系统

危害
远程攻击者可以利用漏洞可获得数据库信息或控制应用系统。

攻击所需条件
攻击者必须访问PHP-Nuke。

漏洞信息
PHP-Nuke是一款基于PHP的内容管理系统。
PHP-Nuke modules.php脚本不正确过滤”sid”参数,允许攻击者利用漏洞进行SQL注入攻击,可获得数据库信息或控制应用系统。

测试方法
http://www.example.com/modules.php?name=News&file=article&sid=13[SQL]

厂商解决方案
目前没有详细解决方案提供:
http://www.phpnuke.org/

漏洞提供者
Ashiyane Digital Security Team