Python哈希冲突拒绝服务漏洞

受影响系统:

Python python < 2.6.8

描述:


CVE ID: CVE-2012-1150

Python是一种面向对象、直译式计算机程序设计语言。

Python 2.6.8之前版本、2.7.x、3.x、3.2.x版本计算哈希值时没有预先限制哈希冲突,可允许攻击者通过向包含哈希表的应用发送特制的应用支持拒绝服务。

<*来源:vendor

链接:http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-1150
*>

建议:


厂商补丁:

Python
——
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

www.python.org