WordPress WP e-Commerce插件多个安全漏洞

漏洞起因
输入验证错误
危险等级

影响系统
WordPress WP e-Commerce 3.8.9.5

不受影响系统

危害
远程攻击者可以利用漏洞可获取敏感信息,执行任意代码等。
CVSSv2:

攻击所需条件
攻击者必须访问WordPress WP e-Commerce。

漏洞信息
WordPress是一种使用PHP语言开发的博客平台,用户可以在支持PHP和MySQL数据库的服务器上架设自己的网志。
WordPress WP e-Commerce存在多个安全漏洞,允许攻击者利用漏洞进行本地包含,跨站脚本,跨站请求伪造,文件上传及任意代码执行攻击,可获取敏感信息,执行任意代码等。

测试方法
本地文件包含
http://www.example.com/wp-e-commerce/wpsc-includes/misc.functions.php?image_name=[LFI]
远程代码执行
http://www.example.com/wp-e-commerce/wpsc-admin/ajax.php?wpsc_action=[CMD]
http://www.example.com/wp-e-commerce/wpsc-admin/display-sales-logs.php?c=[CMD]
安全建议

厂商解决方案
Seo Panel 3.4.0已经修复该漏洞,建议用户下载更新:
http://wordpress.org/plugins/wp-e-commerce

漏洞提供者
KedAns-Dz