WordPress WP-Cron Dashboard Plugin ‘procname’参数跨站脚本漏洞

漏洞起因
输入验证错误
危险等级

影响系统
Wordpress WP-Cron Dashboard Plugin 1.1.5

不受影响系统

危害
远程攻击者可以利用漏洞可获取敏感信息或者劫持用户会话。
CVSSv2:

攻击所需条件
攻击者必须构建恶意URI,诱使用户解析。

漏洞信息
WordPress是一种使用PHP语言开发的博客平台,用户可以在支持PHP和MySQL数据库的服务器上架设自己的网志。
WWordpress WP-Cron Dashboard插件”/wp-admin/tools.php”脚本不正确过滤用户通过”procname” HTTP POST参数提供的输入,允许远程攻击者利用漏洞构建恶意URI,诱使用户解析,当恶意数据被查看时可获取敏感信息或者劫持用户会话。

测试方法



安全建议

厂商解决方案
目前没有详细解决方案提供:
http://wordpress.org/plugins/wp-cron-dashboard/

漏洞提供者
High-Tech Bridge Security Research Lab