Python多个安全漏洞

漏洞起因
设计错误
危险等级

影响系统
Python 2.6.x

不受影响系统

危害
远程攻击者可以利用漏洞可使应用程序崩溃。
CVSSv2:

攻击所需条件
攻击者必须访问Python。

漏洞信息
Python是一款开放源代码的脚本编程语言。
Python存在多个安全漏洞,允许远程攻击者利用漏洞进行伪造攻击和进行拒绝服务攻击。
1,Python SSL模块没有正确处理服务器SSL证书中的”subjectAltNames”通用名的空字节,允许攻击者通过中间人攻击进行服务器伪造攻击,可获取敏感信息。
2,不受限的调用Lib/httplib.py中的”readline()”可导致消耗大量内存资源,造成拒绝服务攻击。
3,不受限的调用Lib/ftplib.py中的”readline()”可导致消耗大量内存资源,造成拒绝服务攻击。
4,不受限的调用Lib/imaplib.py中的”readline()”可导致消耗大量内存资源,造成拒绝服务攻击。
5,不受限的调用Lib/nntplib.py中的”readline()”可导致消耗大量内存资源,造成拒绝服务攻击。
6,不受限的调用Lib/poplib.py中的”readline()”可导致消耗大量内存资源,造成拒绝服务攻击。
7,不受限的调用Lib/smtplib.py中的”readline()”可导致消耗大量内存资源,造成拒绝服务攻击。

测试方法
安全建议

厂商解决方案
Python 2.6.9已经修复该漏洞,建议用户下载更新:
http://www.python.org

漏洞提供者
1)Ryan Sleevi, Google Chrome Security Team.
2-7) Reported by the vendor.