Apache Sling ‘deepGetOrCreateNode()’函数远程拒绝服务漏洞

漏洞起因
异常条件处理失败错误
危险等级

影响系统
Apache Sling 2.2.0
Apache Sling 2.3.0

不受影响系统

危害
远程攻击者可以利用漏洞可使应用程序崩溃,造成拒绝服务攻击。
CVSSv2:

攻击所需条件
攻击者必须访问Apache Sling。

漏洞信息
Apache Sling是一个使用Java内容库如Apache Jackrabbit存储和管理内容的Web 框架。
组合一些访问控制设置和请求路径,可使Apache Sling org.apache.sling.servlets.post bundle 2.2.0和2.3.0中的POST Servlet导致死循环,允许攻击者利用漏洞提交恶意请求进行拒绝服务攻击。

测试方法
安全建议

厂商解决方案
Apache Sling 2.3.2已经修改该漏洞,建议用户下载更新:
http://sling.apache.org/downloads.cgi

漏洞提供者
Antonio Sanso of Adobe