Drupal Inf08 theme跨站脚本漏洞

漏洞起因
跨站脚本错误
危险等级

影响系统
Drupal Inf08 theme 6.x-1.x

不受影响系统

危害
远程攻击者可以利用漏洞可获取敏感信息或者劫持用户会话。
CVSSv2:

攻击所需条件
攻击者必须访问Drupal Inf08 theme。

漏洞信息
Drupal是一款流行的内容管理系统。
Drupal Inf08 theme中phptemplate_preprocess_node函数(template.php)存在跨站脚本漏洞,允许通过验证的拥有”administer taxonomy”的远程攻击者利用漏洞注入恶意WEB脚本或HTML代码,可获取敏感信息或者劫持用户会话。

测试方法
安全建议

厂商解决方案
Drupal Inf08 theme 6.x-1.10已经修复此漏洞,建议用户下载更新:
http://drupal.org/project/inf08

漏洞提供者
Justin C. Klein Keane