Apache Santuario XML Security for C++ 堆缓冲区溢出漏洞(CVE-2013-2210)

受影响系统:
Apache Group XML Security for C++ 1.6.1
Apache Group XML Security for C++ 1.6
描述:
BUGTRAQ ID: 60817
CVE(CAN) ID: CVE-2013-2210

Apache Santuario是实现XML的主要安全标准。

Apache Santuario XML Security for C++ 1.7.2之前版本在XPointer求值中存在堆缓冲区溢出漏洞,成功利用后可允许远程攻击者在受影响应用上下文中执行任意代码。此漏洞是在CVE-2013-2154修复中引入的,源于XML签名引用处理代码中的畸形XPointer表达式处理。

<*来源:Jon Erickson 链接:http://seclists.org/bugtraq/2013/Jun/108 *>

建议:
厂商补丁:

Apache Group
————
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://svn.apache.org/viewvc?view=revision&revision=r1496703