MyBB权限校验安全绕过漏洞

漏洞起因
访问验证错误
危险等级

影响系统
MyBB (formerly MyBulletinBoard) 1.x

不受影响系统

危害
远程攻击者可以利用漏洞绕过安全限制访问受限内容。
CVSSv2:

攻击所需条件
攻击者必须访问MyBB。

漏洞信息
MyBB是一款基于PHP的流行的论坛程序。
在以”View only own threads”标记访问论坛时应用程序不正确校验权限,允许远程攻击者利用该漏洞访问其他受限论坛主题中的敏感信息。

测试方法

厂商解决方案
MyBB 1.6.10已经修复此漏洞,建议用户下载更新:
http://www.mybb.com

漏洞提供者
Jordan Mussi and StefanT