WebKit ‘CompositeEditCommand::cloneParagraphUnderNewElement’释放后使用漏洞

漏洞起因
释放后使用错误
危险等级

影响系统
WebKitGTK+ 2.0.1
Google Chrome

不受影响系统
远程攻击者利用漏洞可以应用程序上下文执行任意代码。
CVSSv2:9.3 (AV:N/AC:M/Au:N/C:C/I:C/A:C)

攻击所需条件
攻击者必须构建恶意WEB页,诱使用户解析。

漏洞信息
WebKit是一款开放源代码的浏览器引擎。
WebKit WebCore/editing/CompositeEditCommand.cpp中的’CompositeEditCommand::cloneParagraphUnderNewElement’函数在克隆段落时存在一个释放后使用错误,允许攻击者构建恶意WEB页,诱使用户解析,引用已释放内存而执行任意代码。

测试方法

厂商解决方案
用户可参考如下厂商提供的安全公告获得补丁信息:
http://trac.webkit.org/changeset/148908
https://src.chromium.org/viewvc/blink?revision=148680&view=revision

漏洞提供者
vendor