Apache Qpid拒绝服务漏洞

漏洞起因
边界条件错误
危险等级

影响系统
Apache Qpid 0.x

不受影响系统

危害
远程攻击者可以利用漏洞造成拒绝服务攻击。

攻击所需条件
攻击者必须访问Apache Qpid。

漏洞信息
Apache Qpid(Open Source AMQP Messaging)是一个跨平台的企业通讯解决方案,实现了高级消息队列协议。
Apache Qpid中的AMQP type decoder接收某些消息时存在安全漏洞,远程攻击者可以利用此漏洞发送特制的connection.start-ok消息,使qpidd崩溃,造成拒绝服务攻击。

测试方法

厂商解决方案
用户可参考如下厂商提供的补丁信息:
https://svn.apache.org/viewvc?view=revision&revision=1453031

漏洞提供者
Florian Weimer, Red Hat Product Security Team.