Drupal Varnish HTTP Accelerator Integration模块跨站脚本漏洞

漏洞起因
跨站脚本错误
危险等级

影响系统
Drupal Varnish HTTP Accelerator Integration 6.x-1.x
Drupal Varnish HTTP Accelerator Integration 7.x-1.x

不受影响系统

危害
远程攻击者可以利用漏洞可获得敏感信息或劫持用户会话。

攻击所需条件
攻击者必须访问Drupal Varnish HTTP Accelerator Integration。

漏洞信息
Drupal是一款开源的内容管理系统。
Drupal Varnish HTTP Accelerator Integration不正确过滤用户提交的数据,允许远程攻击者利用漏洞构建恶意WEB页,诱使用户解析,可获得敏感信息或劫持用户会话。

测试方法

厂商解决方案
Drupal Varnish HTTP Accelerator Integration 6.x-1.2和7.x-1.0-beta2已经修复此漏洞,建议用户下载使用:
http://drupal.org/project/varnish

漏洞提供者
Ivo Van Geertruyen