Drupal Video模块任意PHP代码执行漏洞 | ZeroBox Vulnerability Database

Drupal Video模块任意PHP代码执行漏洞

漏洞起因
输入验证错误
危险等级

影响系统
Drupal Video module 7.x-2.x

不受影响系统

危害
远程攻击者利用漏洞执行任意PHP代码。

攻击所需条件
攻击者必须访问Drupal Video模块。

漏洞信息
Drupal是一款流行的内容管理系统。
Drupal Video模块会把FFmpeg可执行文件的信息保存到临时PHP文件中,但没有读取文件时没有对文件是否篡改进行检查,允许执行文件中的任意PHP代码。

测试方法

厂商解决方案
Drupal Video module 7.x-2.9已经修复此漏洞,建议用户下载使用:
http://drupal.org/project/video

漏洞提供者
Joris van Eijden