Drupal CurvyCorners模块跨站脚本漏洞 | ZeroBox Vulnerability Database

Drupal CurvyCorners模块跨站脚本漏洞

漏洞起因
跨站脚本错误
危险等级

影响系统
Drupal CurvyCorners module 6.x-1.x
Drupal CurvyCorners module 7.x-1.x

不受影响系统

危害
远程攻击者利用漏洞可获得敏感信息或劫持用户会话。

攻击所需条件
攻击者必须访问Drupal CurvyCorners模块。

漏洞信息
Drupal是一款流行的内容管理系统。
Drupal CurvyCorners模块在显示用户提交的输入文本时没有进行正确过滤,允许攻击者利用漏洞进行跨站脚本攻击,可获得敏感信息或劫持用户会话。

测试方法

厂商解决方案
目前没有详细解决方案提供:
http://drupal.org/project/curvycorners

漏洞提供者
rickauer