WordPress Store Locator Plus插件’query’参数SQL注入漏洞

漏洞起因
SQL注入错误
危险等级

 
影响系统
WordPress Store Locator Plus Plugin 3.x
 
不受影响系统
 
危害
远程攻击者可以利用漏洞可获得敏感信息或控制应用系统。
 
攻击所需条件
攻击者必须访问WordPress Store Locator Plus插件。
 
漏洞信息
WordPress是一款开源的内容管理系统。
通过”query”参数传递给Store Locator Plus插件wp-content/plugins/store-locator-le/downloadcsv.php脚本的输入在用于SQL查询之前缺少过滤,可导致远程攻击者利用漏洞进行SQL注入攻击,可获得敏感信息或控制应用系统。
 
测试方法
 
厂商解决方案 
WordPress Store Locator Plus Plugin 3.8.7已经修复此漏洞,建议用户下载使用:
http://wordpress.org/extend/plugins/store-locator-le/changelog/
 
漏洞提供者
vendor