WordPress WooCommerce Predictive Search Plugin ‘rs’跨站脚本漏洞

漏洞起因
跨站脚本错误
危险等级

影响系统
WordPress WooCommerce Predictive Search Plugin 1.x

不受影响系统

危害
远程攻击者可以利用漏洞可获得敏感信息或劫持用户会话。

攻击所需条件
攻击者必须访问WordPress WooCommerce Predictive Search插件。

漏洞信息
WordPress是一款使用PHP语言开发的内容管理系统。
WordPress WP e-Commerce Predictive Search插件存在安全漏洞,通过”rs”参数传递给index.php的数据在返回用户之前缺少过滤,可导致跨站脚本攻击,可获得敏感信息或劫持用户会话。

测试方法

厂商解决方案
WordPress WooCommerce Predictive Search Plugin 1.1.2已经修复此漏洞,建议用户下载使用:
http://wordpress.org/extend/plugins/wp-e-commerce-predictive-search/changelog/

漏洞提供者
Jason Flemming