Drupal Printer, email和PDF模块跨站脚本漏洞

漏洞起因
跨站脚本错误
危险等级

影响系统
Drupal Printer, email and PDF versions 7.x-1.0-beta2
Drupal Printer, email and PDF versions 6.x-1.14

不受影响系统

危害
远程攻击者可以利用漏洞获得敏感信息或控制应用系统。

攻击所需条件
攻击者必须访问Drupal Printer, email和PDF模块。

漏洞信息
Drupal是一款使用PHP语言开发的内容管理系统。
Drupal Printer, email和PDF模块存在跨站脚本漏洞,允许攻击者利用漏洞注入任意WEB脚本或HTML,可获得敏感信息或劫持用户会话。

测试方法

厂商解决方案
Drupal Printer, email and PDF versions 7.x-1.0和6.x-1.15已经修复此漏洞,建议用户下载使用:
http://drupal.org/node/1515060
http://drupal.org/node/1515076

漏洞提供者
Shlomi Zadok and Ivan Bueno