Python tweepy模块库SSL证书验证安全限制绕过漏洞

受影响系统:
Python tweepy Module 1.x
描述:
BUGTRAQ ID: 56410
CVE ID: CVE-2012-5825

Python是一种面向对象、直译式计算机程序设计语言。

Python tweepy库1.11及其他版本存在安全限制绕过漏洞,成功利用后可允许攻击者执行中间人攻击或模拟受信任服务器。

<*来源:ACM CCS 2012 conference 链接:http://secunia.com/advisories/51223/ http://www.cs.utexas.edu/~shmat/shmat_ccs12.pdf *>

建议:
厂商补丁:

Python
——
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

www.python.org