Red Hat Enterprise MRG Grid CVE-2012-2685内存破坏漏洞

漏洞起因
设计错误
危险等级

影响系统
RedHat Enterprise Linux 5.0
Red Hat Enterprise Linux 6
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0

不受影响系统

危害
远程攻击者可以利用漏洞进行拒绝服务攻击。

攻击所需条件
攻击者必须访问Red Hat Enterprise MRG Cumin。

漏洞信息
Red Hat Enterprise MRG是一款Redhatlinux发行的即时通信网格解决方案。
Cumin处理图像请求存在错误,可导致分配任意大小图像,引起内存破坏造成拒绝服务攻击。

测试方法

厂商解决方案
用户可参考如下SVN库获得相关的补丁信息:
http://svn.fedorahosted.org/svn/cumin

漏洞提供者
Florian Weimer, the Red Hat Product Security Team