Debian devscripts CVE-2012-2242任意代码执行漏洞

漏洞起因
输入验证错误
危险等级

影响系统
Debian devscripts

不受影响系统

危害
远程攻击者可以利用漏洞执行任意代码。

攻击所需条件
攻击者必须访问Debian devscripts。

漏洞信息
Debian devscripts是debian系统中的一些工具集合。
处理特制的.dsc或.changes文件时,dget没有正确转义传递给外名命令的参数,允许攻击者进行执行任意代码。

测试方法

厂商解决方案
用户可参考如下供应商提供的安全公告获得补丁信息:
http://www.debian.org/security/2012/dsa-2549

漏洞提供者
Raphael Geissert