Linux Kernel Netlink消息处理本地权限提升漏洞

漏洞起因
设计错误
危险等级

影响系统
Linux Kernel 3.2.x
Linux Kernel 3.4.x
Linux Kernel 3.5.x

不受影响系统

危害
本地攻击者可以利用漏洞提升权限。

攻击所需条件
攻击者必须访问Linux。

漏洞信息
Linux是一款开源的操作系统。
Linux内核存在安全漏洞,允许本地用户利用漏洞提升权限。
由于内核非法处理SCM_CREDENTIALS传递,本地攻击者可以利用漏洞伪造Netlink消息,以高特权执行任意操作。

测试方法

厂商解决方案
用户可参考如下供应商提供的安全公告获得补丁信息:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=e0e3cea46d31

漏洞提供者
Pablo Neira Ayuso

评论关闭。