Joomla! CVE-2012-2412跨站脚本漏洞

漏洞起因
跨站脚本错误
危险等级

影响系统
Joomla! 2.5.4
Joomla! 2.5.3
Joomla! 2.5.2
Joomla! 2.5.1
Joomla! 2.5

不受影响系统

危害
远程攻击者可以利用漏洞可获得敏感信息或劫持用户会话。

攻击所需条件
攻击者必须访问Joomla!。

漏洞信息
Joomla!是基于php+mysql模式的快速建站系统。
“sysinfo.php”脚本不正确过滤用户提供的User-Agent字符串,攻击者可以利用漏洞进行反射型跨站脚本攻击,可获得敏感信息或劫持用户会话。

测试方法

厂商解决方案
目前没有详细解决方案提供:
http://www.joomla.org/

漏洞提供者
Janek Vind