OpenSSL CMS / PKCS #7解密”Million Message Attack”漏洞

漏洞起因
设计错误
危险等级

影响系统
OpenSSL 0.x
OpenSSL 1.x

不受影响系统

危害
远程攻击者可以利用漏洞解密信息。

攻击所需条件
攻击者必须访问OpenSSL。

漏洞信息
OpenSSL是一款开放源码的SSL实现,用来实现网络通信的高强度加密。
OpenSSL CMS和PKCS #7解密代码存在安全漏洞,允许攻击者使用熟知的”million message attack (MMA)”,针对CMS, PKCS #7或S/MIME进行解密操作,要成功利用漏洞需要发送平均2^20的消息。

测试方法

厂商解决方案
OpenSSL 1.0.0h或0.9.8u已经修复此漏洞,建议用户下载使用:
http://www.openssl.org/

漏洞提供者
Ivan Nestlerode

评论关闭。