PHP “zend_strndup()”多个空指针引用拒绝服务漏洞

受影响系统:

PHP PHP 5.3.8

描述:


BUGTRAQ  ID: 51417
CVE ID: CVE-2011-4153

PHP是一种在电脑上运行的脚本语言,主要用途是在于处理动态网页,包含了命令行运行接口或者产生图形用户界面程序。

PHP在检验zend_strndup()调用的返回值的实现上存在多个拒绝服务漏洞,攻击者可利用这些漏洞造成受影响应用崩溃,拒绝服务合法用户。

<*来源:Maksymilian Arciemowicz (max@jestsuper.pl

链接:http://cxsecurity.com/issue/WLB-2012010103
*>

建议:


厂商补丁:

PHP

目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.php.net