Novell Open Enterprise Server iPrint远程缓冲区溢出漏洞

受影响系统:

Novell Open Enterprise Server 2.0.3
Novell Open Enterprise Server 2.0.2

描述:

Novell Open Enterprise Server是网络、通信及协作服务的业务平台。

Novell Open Enterprise Server在实现上存在远程缓冲区溢出漏洞,远程攻击者可利用此漏洞在受影响应用程序中执行任意代码,造成拒绝服务。

此漏洞源于与TCP端口515上监听的"ilprsrvd"通讯的"/opt/novell/iprint/bin/ipsmd"组件。在处理多个LPR操作码时,进程盲目复制用户提供的数据到栈上固定长度的缓冲区。

<*来源:Francis Provencher
  
  链接:
http://marc.info/?l=bugtraq&m=129796089510122&w=2
*>

建议:

厂商补丁:

Novell
——
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://support.novell.com/security-alerts

发表评论?

0 条评论。

发表评论