Mozilla Firefox/Thunderbird/SeaMonkey "document.write()"缓冲区溢出漏洞

受影响系统:

Mozilla Firefox 3.5.11- 3.6.10
Mozilla Thunderbird 3.0 – 3.1.5
Mozilla SeaMonkey 2.0.1 – 2.0.10

不受影响系统:

Mozilla Firefox 3.6.13
Mozilla Firefox 3.5.16
Mozilla Thunderbird 3.1.7
Mozilla Thunderbird 3.0.11
Mozilla SeaMonkey 2.0.11

描述:
Firefox是一款非常流行的开源WEB浏览器。Thunderbird是一个邮件客户端,支持IMAP、POP邮件协议以及HTML邮件格式。SeaMonkey是开源的Web浏览器、邮件和新闻组客户端、IRC会话客户端和HTML编辑器。

Mozilla Firefox、Thunderbird和SeaMonkey中存在漏洞。攻击者可利用这些漏洞在受影响的应用程序中执行任意代码。

此漏洞源于在Windows平台上,当用过长的字符串调用document.write()时,会导致在换行例程尝试处理要显示的字符串时引起缓冲区溢出。

<*来源:Dirk Heinrich
  
  链接:
http://www.mozilla.org/security/announce/2010/mfsa2010-75.html
*>

建议: 厂商补丁:

Mozilla
——-
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.mozilla.org/

发表评论?

0 条评论。

发表评论